Tag Archives: ISP

Moving to a Faster ISP

Recently moved from Austin, TX to Montreal, Qc. The move implied an ISP change and I was wondering what the results would be.

My previous ISP plan was AT&T Yahoo’s Pro DSL (3.0Mbps/512kbps). It cost 25$/mo. (without a contract). Here were the results from DSL Reports using that connection on a MacBook through WiFi (802.11g).

In Montreal, I’m now using Vif‘s ADSL Monthly (5.0Mbps/800kbps). It’s 30$/mo. (no contract). Setup was very easy (nice to be able to choose your own PPPoE username and password!). The connection seems reliable enough. And it is, in fact, much faster than what I had in Austin.

Using the same MacBook and WiFi router, I now get the following results:

Latency is the same, upstream is 50% faster, downstream is 140% faster.

Thing is, though, I’m not really sure I see much of a difference. Sure, it can be quite useful for some downloads and, since this connection will be shared with somebody else in the house, it might make things easier. But it still feels a bit like overkill.

The other issue is whether or not this connection gets throttled at all. Vif itself won’t throttle. But they use Bell Canada’s lines and it seems possible that Bell throttles third-party ISPs using its lines. Though I don’t use much “peer-to-peer” directly, throttling can be very problematic.

Anyhoo… The ISP switch looks like a good thing so far.


AT&T Yahoo Pro DSL to Belkin WiFi

Doh!
Was trying to set up my Belkin Wireless G Router (F5D7230-4) for use with our “Pro DSL” broadband connection from AT&T Yahoo (with a Motorola 2210 ADSL modem). It always stopped at authentication even though both of our computers (a MacBook and an eMachines H3070) could use the connection directly. Tried just about everything I could from doing a manual setup or resetting the router and the DSL modem, to updating the firmware or changing the connection’s password.
Most Web searches led me to irrelevant results. Nobody seemed to be having the same problem as I was. To be honest, my frustration was mounting. I almost called tech support!
 
Then, I noticed that the following forum post kept creeping up in search results, even though it didn’t have anything to do with AT&T.
It then dawned on me that the problem may be simpler than I thought. Maybe my assumption was wrong, that this connection was using PPPOE like Sympatico, my previous ISP.
So, pretty much on a whim, I tried changing the connection type from PPPOE to Dynamic IP. And everything worked flawlessly.
Apart from experience with Bell’s Sympatico service, I was probably misled by the fact that this AT&T DSL connection was configured for use with a special @att.net account and a password. AFAICT, this att.net account isn’t necessary for the connection (but is provided with the connection). 
 
After setting all of this up, I set up my Fonera WiFi router. “But you’re already using the Belkin Wireless G Router!,” you say? Well, yes. But I’m using the Fonera so I can easily share my connection with other Foneros. There’s already a few of us, Austin members of the Fon Movimiento. Not that we know each other. But we all share our broadband connection for free.
Why would we do such a thing?
Because we can.